Achieving HDMI audio output with ATI hardware on Windows 7 (and Vista)

A lot of people seem to have had issues with Vista and HDMI when using a receiver as part of the system, it seems to be related to when you switch inputs it can mess up Windows screen resolution when using ATI hardware.  In Windows 7 the problem has got even worse because the ATI drivers seem to hand over all of the resolution settings to Windows which means you can’t set up a macro to change the resolution. Fortunately there is a solution details on this great blog post:

I did a great deal of digging and found a whole heap of discussion related to this issue on the fantastic AV Science Forum. The problem, it turns out, is widespread, and afflicts owners of ATI hardware the world over when connecting to AV receivers of all makes and models. The root cause seems to centre around the capabilities information passed down the HDMI connection when plugged into the AV receiver. For some reason, it seems to confuse the capabilities of the TV and receiver in such a way as to convince the PC that audio is not supported.

The solution, it turns out, is to create your own device driver .inf file which details correctly the capabilities of the TV and receiver and overrides the connection information.

The forums had much discussion involving registry hacking, copying and pasting of hex data into. inf files and much more. However, they also focused on a tool referred to in the forums as moninfo. A bit of googling later and it turns out they mean Monitor Asset Manager – a free utility from EnTech, makers of the mighty PowerStrip shareware tool.

Checkout the blog post for the rest of the details and thanks to pappleya for the tip

Share

One thought on “Achieving HDMI audio output with ATI hardware on Windows 7 (and Vista)

  1. I have a simular issue, except it is with the video driver on my Dell Studio Hybrid. Is uses an on board Intel Mobil 965 Express Chipset for video. The issue is if I recycle power on my HDTV the video card may hang. This seems to happen when I power up. If i put the PC in sleep mode prior to turning the HDTV on the video driver is fine. THe Dell PC uses an HDMI connection. Do you think this might address this problem?

Leave a Reply

Your email address will not be published. Required fields are marked *